Template:Versioni compatibili

Da Guide@Debianizzati.Org.

Introduzione

Questo template permette di segnalare le versioni di Debian compatibili con una guida, e il suo uso è obbligatorio per tutte le guide relative a questo sistema operativo. È preferibile che le versioni elencate siano solo quelle per cui la guida è stata esplicitamente testata, o in alternativa che contengono le stesse versioni dei pacchetti trattati.

Per le guide divise in più pagine è raccomandata l'inclusione del template soltanto nella principale.

Uso

Parametri

Debian-swirl.png Versioni Compatibili
Debian 8 "Jessie"
Debian 9 "Stretch"

Aggiungere un parametro per ogni versione compatibile, separati tra loro da un carattere "|". Il nome da inserire è il codename di Debian, ovvero il nome del personaggio di Toy Story a cui la versione specifica è dedicata. La lista completa è riportata in seguito.

Si noti che tutti i pacchetti presenti in testing e unstable possono ricevere aggiornamenti che ne alterano le funzionalità, oppure essere rimossi durante la fase di freeze o prima ancora, motivo per cui in questo template si è scelto di prediligere la compatibilità per l'attuale stable e versioni precedenti di Debian. Per garantire in futuro che tutte le guide verificate per "Buster" siano testate per quella che sarà la versione stable rilasciata, si riservano i codename per le sole versioni stable e precedenti di Debian, mentre per le più recenti si utilizzano la suite e l'ultimo anno di verifica.

Per esempio:

{{Versioni compatibili|Jessie|Stretch}}

Oppure con Stretch, testing (Buster) e unstable/Sid:

{{Versioni compatibili|Stretch|Testing_2017|Unstable_2017}}

Numero massimo di parametri: 5

Codename ammessi (per Debian stable e precedenti):

Suite ammesse (per testing e Sid):

Se si supera il numero massimo di parametri ammessi, è possibile rimuovere le versioni non più supportate. Essendo permessi fino a 5 parametri, è sempre possibile indicare la compatibilità per le attuali LTS, oldstable, stable, testing e unstable/Sid.

Per testing e unstable, si deve utilizzare sempre soltanto un singolo parametro, quello relativo all'ultimo anno di revisione, aggiornandolo quando si effettua una nuova revisione per la stessa versione o rimuovendolo se si considera ormai obsoleta.

I parametri del template inoltre devono essere ordinati per versione, partendo dalla meno recente (ordine crescente).

Non compatibilità

Debian-swirl.png Versioni Compatibili
soltanto:
Debian 8 "Jessie"

Utilizzando la stringa ONLY come primo parametro, è possibile utilizzare questo template per segnalare che soltanto le versioni esplicitamente elencate con i parametri successivi sono supportate.

Si consideri che il limite di cinque parametri è ancora valido, e pertanto soltanto altri quattro parametri sono possibili, scegliendoli tra gli stessi ammessi nella sezione precedente.

Tali guide, quando contengono soltanto l'attuale oldstable, saranno anche rimosse dall'elenco di quelle da verificare con la versione stable corrente di Debian.

Per esempio:

{{Versioni compatibili|ONLY|Jessie}}

Inoltre una guida segnalata esplicitamente come non compatibile per altre versioni può diventare obsoleta, ma non da controllare o da adottare.

Nessun parametro

Debian-swirl.png Versioni Compatibili
Tutte le versioni supportate di Debian

Se non vengono aggiunti parametri, la guida è compatibile con tutte le versioni supportate di Debian.

Per "versioni supportate" si intendono tutte le seguenti: LTS, oldstable, stable, testing e unstable/Sid.

È sconsigliata questa forma, salvo si tratti di guide teoriche o per pacchetti base del sistema (Priorità del pacchetto: required, important o standard), in quanto la compatibilità della guida non è tracciabile in automatico dalle categorie nascoste. Pertanto le guide non solo teoriche, che non sono più relative a pacchetti base del sistema al rilascio della nuova versione stable di Debian, possono essere modificate per aggiungere al template soltanto le versioni precedenti.

Per esempio:

{{Versioni compatibili}}

Categorie nascoste

Questo template associa in automatico delle categorie, per poter trovare rapidamente le guide compatibili con una data versione:

Oppure, se viene utilizzato questo template con dei parametri, per permettere la ricerca in base alla mancanza di verifiche:

Per finire le guide contenenti errori con questo template sono rintracciabili in questa categoria.

Strumenti personali
Namespace
Varianti
Azioni
Navigazione
Risorse
Strumenti