Repository ufficiali

Da Guide@Debianizzati.Org.

(Differenze fra le revisioni)
(Vecchia stabile: Debian Lenny)
m (le traduzioni dei nomi in codice non si possono leggere)
Riga 7: Riga 7:
Di seguito troverete l'elenco dei repository ufficiali da inserire nel file <code>/etc/apt/sources.list</code> per le varie [[La struttura della Distribuzione|versioni di Debian]]. Il mirror è quello italiano. I repository dei pacchetti sorgente sono commentati. Per ulteriori informazioni leggere la sezione: [[I repository ed il loro utilizzo#Sources.list|Sources.list]].
Di seguito troverete l'elenco dei repository ufficiali da inserire nel file <code>/etc/apt/sources.list</code> per le varie [[La struttura della Distribuzione|versioni di Debian]]. Il mirror è quello italiano. I repository dei pacchetti sorgente sono commentati. Per ulteriori informazioni leggere la sezione: [[I repository ed il loro utilizzo#Sources.list|Sources.list]].
-
== Stabile: Debian Squeeze ==
+
== Stable: Debian Squeeze ==
<pre>
<pre>
   ## Debian Stable (Squeeze)
   ## Debian Stable (Squeeze)
Riga 32: Riga 32:
</pre>
</pre>
-
== Instabile: Debian Sid ==
+
== Unstable: Debian Sid ==
<pre>
<pre>
   ## Debian Unstable (Sid)
   ## Debian Unstable (Sid)
Riga 40: Riga 40:
Per '''Sid''' non c'è il repository per la sicurezza dato che eventuali falle vengono corrette semplicemente con l'aggiornamento del pacchetto incriminato.
Per '''Sid''' non c'è il repository per la sicurezza dato che eventuali falle vengono corrette semplicemente con l'aggiornamento del pacchetto incriminato.
-
== Vecchia stabile: Debian Lenny ==
+
== Oldstable (la vecchia stable): Debian Lenny ==
{{Warningbox|Il supporto per Debian 5.0 "Lenny" [http://www.debian.org/News/2012/20120209 è terminato] il 6 febbraio 2012. A partire da questa data non sono più presenti gli aggiornamenti dei pacchetti per la correzione di eventuali bug. È vivamente consigliato aggiornare il sistema a Debian 6.0 "Squeeze" oppure utilizzare gli [[archivi Debian]].}}
{{Warningbox|Il supporto per Debian 5.0 "Lenny" [http://www.debian.org/News/2012/20120209 è terminato] il 6 febbraio 2012. A partire da questa data non sono più presenti gli aggiornamenti dei pacchetti per la correzione di eventuali bug. È vivamente consigliato aggiornare il sistema a Debian 6.0 "Squeeze" oppure utilizzare gli [[archivi Debian]].}}
<pre>
<pre>

Versione delle 15:00, 24 ott 2012

I repository

Introduzione ai repository

Repository ufficiali di Debian

Repository esterni

Extra



Debian-swirl.png Versioni Compatibili
Tutte le versioni supportate di Debian

Indice

Lista repository ufficiali Debian

Di seguito troverete l'elenco dei repository ufficiali da inserire nel file /etc/apt/sources.list per le varie versioni di Debian. Il mirror è quello italiano. I repository dei pacchetti sorgente sono commentati. Per ulteriori informazioni leggere la sezione: Sources.list.

Stable: Debian Squeeze

  ## Debian Stable (Squeeze)
  deb http://ftp.it.debian.org/debian/ squeeze main
  #deb-src http://ftp.it.debian.org/debian/ squeeze main
 
  ## Aggiornamenti della sicurezza
  deb http://security.debian.org/ squeeze/updates main
  #deb-src http://security.debian.org/ squeeze/updates main

Per avere pacchetti più aggiornati per Lenny e Squeeze si possono usare i backport:

Testing: Debian Wheezy

  ## Debian Testing (Wheezy)
  deb http://ftp.it.debian.org/debian/ wheezy main
  #deb-src http://ftp.it.debian.org/debian/ wheezy main
 
  ## Aggiornamenti della sicurezza
  deb http://security.debian.org/ wheezy/updates main
  #deb-src http://security.debian.org/ wheezy/updates main

Unstable: Debian Sid

  ## Debian Unstable (Sid)
  deb http://ftp.it.debian.org/debian/ unstable main
  #deb-src http://ftp.it.debian.org/debian/ unstable main

Per Sid non c'è il repository per la sicurezza dato che eventuali falle vengono corrette semplicemente con l'aggiornamento del pacchetto incriminato.

Oldstable (la vecchia stable): Debian Lenny

Warning.png ATTENZIONE
Il supporto per Debian 5.0 "Lenny" è terminato il 6 febbraio 2012. A partire da questa data non sono più presenti gli aggiornamenti dei pacchetti per la correzione di eventuali bug. È vivamente consigliato aggiornare il sistema a Debian 6.0 "Squeeze" oppure utilizzare gli archivi Debian.


 #debian lenny
 deb http://archive.debian.org/debian/ lenny main 
 deb-src http://archive.debian.org/debian/ lenny main 
 # Security:
 deb http://archive.debian.org/debian-security/ lenny/updates main 
 deb-src http://archive.debian.org/debian-security/ lenny/updates main 
 # Volatile:
 deb http://archive.debian.org/debian-volatile lenny/volatile main 
Strumenti personali
Namespace
Varianti
Azioni
Navigazione
Risorse
Strumenti