Template:Versioni compatibili

Da Guide@Debianizzati.Org.

(Differenze fra le revisioni)
m (rimozione categorie nascoste generate dagli esempi (modificata solo parte <noinclude>, e solo nel sorgente) - parte 1/2)
m (rimozione categorie nascoste generate dagli esempi (modificata solo parte <noinclude>, e solo nel sorgente) - parte 2/3)
Riga 64: Riga 64:
=== Parametri ===
=== Parametri ===
-
{{
 
-
#if: {{Codename|Oldstable}} | {{
 
-
  #switch: {{
 
-
      #if:  | {{{5}}} | {{
 
-
        #if:  | {{{4}}} | {{
 
-
            #if:  | {{{3}}} | {{
 
-
              #if: {{Codename|Stable}} | {{Codename|Stable}} | {{Codename|Oldstable}}
 
-
            }}
 
-
        }}
 
-
      }}
 
-
  }} | Woody | Sarge | Etch | Lenny | Squeeze | Testing_{{#expr: {{CURRENTYEAR}} + 1}} | Unstable_{{#expr: {{CURRENTYEAR}} + 1}} | Testing_{{CURRENTYEAR}} | Unstable_{{CURRENTYEAR}} | Testing_{{#expr: {{CURRENTYEAR}} - 1}} | Unstable_{{#expr: {{CURRENTYEAR}} - 1}} | Testing_{{#expr: {{CURRENTYEAR}} - 2}} | Unstable_{{#expr: {{CURRENTYEAR}} - 2}} | Testing_{{#expr: {{CURRENTYEAR}} - 3}} | Unstable_{{#expr: {{CURRENTYEAR}} - 3}} =
 
-
  | Testing_{{#expr: {{CURRENTYEAR}} - 4}} | Unstable_{{#expr: {{CURRENTYEAR}} - 4}} | Testing_{{#expr: {{CURRENTYEAR}} - 5}} | Unstable_{{#expr: {{CURRENTYEAR}} - 5}} = {{
 
-
      #ifeq: {{Codename|Oldstable}} | ONLY |  | {{Guida da controllare|AUTO}}
 
-
  }}
 
-
  | {{
 
-
      #switch: {{Codename|Stable}} | {{Codename|Oldstable}} | {{Codename|Stable}} |  |  |  =
 
-
      | {{
 
-
        #switch: {{Codename|Oldstable}} | {{Codename|Oldstable}} | {{Codename|Stable}} |  |  |  =
 
-
        | {{
 
-
            #switch: {{Codename|Oldoldstable}} | {{Codename|Oldstable}} | {{Codename|Stable}} |  |  |  = {{
 
-
              #ifeq: {{Codename|Oldstable}} | ONLY |  | {{Guida da controllare|AUTO}}
 
-
            }} | {{
 
-
              #ifeq: {{Codename|Oldstable}} | ONLY |  | {{Guida da controllare|AUTO|NOCATEGORY}}
 
-
            }} [[Categoria:Guide abbandonate]]
 
-
        }}
 
-
      }}
 
-
  }}
 
-
}} |
 
-
}}
 
{|style="float:right; clear:both; width:23%; min-width:133px; margin:0 0 10px 8px; padding-bottom:5px; border-radius:0.5em; border:1px solid #4e88d0; background-color:#f8fbfd; font-variant:small-caps; text-align:center;"
{|style="float:right; clear:both; width:23%; min-width:133px; margin:0 0 10px 8px; padding-bottom:5px; border-radius:0.5em; border:1px solid #4e88d0; background-color:#f8fbfd; font-variant:small-caps; text-align:center;"
-
|[[Image:Debian-swirl.png|33px|link=]] '''Versioni Compatibili''' {{
+
|[[Image:Debian-swirl.png|33px|link=]] '''Versioni Compatibili''' {{#ifeq: {{Codename|Oldstable}} | {{Codename|Stable}} | [[Categoria: Guide compatibili con stable]] |  }}{{
-
#ifeq: {{Codename|Oldstable}} | ONLY | <br />'''soltanto:''' |  }}{{
+
#switch: {{Codename|Oldstable}}
-
#if: {{Codename|Oldstable}} | {{Versioni compatibili elenco|{{Codename|Oldstable}}}}{{
+
| ONLY =
-
  #if: {{Codename|Stable}} | {{Versioni compatibili elenco|{{Codename|Stable}}}}
+
| Woody = <br />Debian 3.0 "Woody"
-
}}{{
+
| Sarge = <br />Debian 3.1 "Sarge"
-
  #if: | {{Versioni compatibili elenco|{{{3}}}}}
+
| Etch = <br />Debian 4 "Etch"
-
}}{{
+
| Lenny = <br />Debian 5 "Lenny"
-
  #if: | {{Versioni compatibili elenco|{{{4}}}}}
+
| Squeeze = <br />Debian 6 "Squeeze"
-
}}{{
+
| Wheezy = <br />Debian 7 "Wheezy"
-
  #if: | {{Versioni compatibili elenco|{{{5}}}}}
+
| Jessie = <br />Debian 8 "Jessie"
-
}}{{
+
| Stretch = <br />Debian 9 "Stretch"
-
  #if: | <br />ERRORE: Consentiti fino a 5 parametri! [[Categoria: Errori nel template Versioni compatibili]] |
+
| Buster = <br />Debian 10 "Buster"
-
}} | <br />Tutte le versioni supportate di Debian [[Categoria: Guide compatibili con tutte le versioni di Debian]] }}{{
+
| Testing_{{CURRENTYEAR}} | Testing_{{#expr: {{CURRENTYEAR}} - 1}} | Testing_{{#expr: {{CURRENTYEAR}} + 1}} = <br/>Debian testing "{{Codename|Testing}}" [[Categoria: Guide compatibili con testing]]
-
#ifeq: {{Codename|Oldstable}} | ONLY | | {{
+
| Testing_{{#expr: {{CURRENTYEAR}} - 2}} | Testing_{{#expr: {{CURRENTYEAR}} - 3}} | Testing_{{#expr: {{CURRENTYEAR}} - 4}} | Testing_{{#expr: {{CURRENTYEAR}} - 5}} | Testing_{{#expr: {{CURRENTYEAR}} - 6}} | Testing_{{#expr: {{CURRENTYEAR}} - 7}} | Testing_{{#expr: {{CURRENTYEAR}} - 8}} | Testing_{{#expr: {{CURRENTYEAR}} - 9}} | Testing_{{#expr: {{CURRENTYEAR}} - 10}} = <br/>Debian testing (non recente) [[Categoria: Guide compatibili con testing (non recenti)]]
-
  #switch: {{Codename|Oldstable}} | {{Codename|Oldstable}} | {{Codename|Stable}} | | | = {{
+
| Unstable_{{CURRENTYEAR}} | Unstable_{{#expr: {{CURRENTYEAR}} - 1}} | Unstable_{{#expr: {{CURRENTYEAR}} + 1}} = <br />Debian "Sid" [[Categoria: Guide compatibili con Sid]]
-
      #switch: {{Codename|Stable}} | {{Codename|Oldstable}} | {{Codename|Stable}} | | | =  
+
| Unstable_{{#expr: {{CURRENTYEAR}} - 2}} | Unstable_{{#expr: {{CURRENTYEAR}} - 3}} | Unstable_{{#expr: {{CURRENTYEAR}} - 4}} | Unstable_{{#expr: {{CURRENTYEAR}} - 5}} | Unstable_{{#expr: {{CURRENTYEAR}} - 6}} | Unstable_{{#expr: {{CURRENTYEAR}} - 7}} | Unstable_{{#expr: {{CURRENTYEAR}} - 8}} | Unstable_{{#expr: {{CURRENTYEAR}} - 9}} | Unstable_{{#expr: {{CURRENTYEAR}} - 10}} = <br/>Debian "Sid" (non recente) [[Categoria: Guide compatibili con Sid (non recenti)]]
-
      | <br />[[:Categoria:Guide non compatibili con stable|Verificala con {{Codename|Stable}}]] [[Categoria: Guide non compatibili con stable]] }}
+
| {{Codename|Testing}} | Testing = <br />ERRORE: utilizzare "Testing_{{CURRENTYEAR}}" come parametro al posto di "{{Codename|Oldstable}}"! Vedi [[Template:Versioni compatibili|qui]]. [[Categoria: Errori nel template Versioni compatibili]]
-
}}
+
| Sid | Unstable = <br />ERRORE: utilizzare "Unstable_{{CURRENTYEAR}}" come parametro al posto di "{{Codename|Oldstable}}"! Vedi [[Template:Versioni compatibili|qui]]. [[Categoria: Errori nel template Versioni compatibili]]
 +
| <br />ERRORE: valore non valido ({{Codename|Oldstable}})! Vedi [[Template:Versioni compatibili|qui]]. [[Categoria: Errori nel template Versioni compatibili]]
 +
}}{{#ifeq: {{Codename|Stable}} | {{Codename|Stable}} | [[Categoria: Guide compatibili con stable]] |  }}{{
 +
#switch: {{Codename|Stable}}
 +
| ONLY =
 +
| Woody = <br />Debian 3.0 "Woody"
 +
| Sarge = <br />Debian 3.1 "Sarge"
 +
| Etch = <br />Debian 4 "Etch"
 +
| Lenny = <br />Debian 5 "Lenny"
 +
| Squeeze = <br />Debian 6 "Squeeze"
 +
| Wheezy = <br />Debian 7 "Wheezy"
 +
| Jessie = <br />Debian 8 "Jessie"
 +
| Stretch = <br />Debian 9 "Stretch"
 +
| Buster = <br />Debian 10 "Buster"
 +
| Testing_{{CURRENTYEAR}} | Testing_{{#expr: {{CURRENTYEAR}} - 1}} | Testing_{{#expr: {{CURRENTYEAR}} + 1}} = <br/>Debian testing "{{Codename|Testing}}" [[Categoria: Guide compatibili con testing]]
 +
| Testing_{{#expr: {{CURRENTYEAR}} - 2}} | Testing_{{#expr: {{CURRENTYEAR}} - 3}} | Testing_{{#expr: {{CURRENTYEAR}} - 4}} | Testing_{{#expr: {{CURRENTYEAR}} - 5}} | Testing_{{#expr: {{CURRENTYEAR}} - 6}} | Testing_{{#expr: {{CURRENTYEAR}} - 7}} | Testing_{{#expr: {{CURRENTYEAR}} - 8}} | Testing_{{#expr: {{CURRENTYEAR}} - 9}} | Testing_{{#expr: {{CURRENTYEAR}} - 10}} = <br/>Debian testing (non recente) [[Categoria: Guide compatibili con testing (non recenti)]]
 +
| Unstable_{{CURRENTYEAR}} | Unstable_{{#expr: {{CURRENTYEAR}} - 1}} | Unstable_{{#expr: {{CURRENTYEAR}} + 1}} = <br />Debian "Sid" [[Categoria: Guide compatibili con Sid]]
 +
| Unstable_{{#expr: {{CURRENTYEAR}} - 2}} | Unstable_{{#expr: {{CURRENTYEAR}} - 3}} | Unstable_{{#expr: {{CURRENTYEAR}} - 4}} | Unstable_{{#expr: {{CURRENTYEAR}} - 5}} | Unstable_{{#expr: {{CURRENTYEAR}} - 6}} | Unstable_{{#expr: {{CURRENTYEAR}} - 7}} | Unstable_{{#expr: {{CURRENTYEAR}} - 8}} | Unstable_{{#expr: {{CURRENTYEAR}} - 9}} | Unstable_{{#expr: {{CURRENTYEAR}} - 10}} = <br/>Debian "Sid" (non recente) [[Categoria: Guide compatibili con Sid (non recenti)]]
 +
| {{Codename|Testing}} | Testing = <br />ERRORE: utilizzare "Testing_{{CURRENTYEAR}}" come parametro al posto di "{{Codename|Stable}}"! Vedi [[Template:Versioni compatibili|qui]]. [[Categoria: Errori nel template Versioni compatibili]]
 +
| Sid | Unstable = <br />ERRORE: utilizzare "Unstable_{{CURRENTYEAR}}" come parametro al posto di "{{Codename|Stable}}"! Vedi [[Template:Versioni compatibili|qui]]. [[Categoria: Errori nel template Versioni compatibili]]
 +
| <br />ERRORE: valore non valido ({{Codename|Stable}})! Vedi [[Template:Versioni compatibili|qui]]. [[Categoria: Errori nel template Versioni compatibili]]
}}
}}
|}
|}
Riga 145: Riga 136:
==== Non compatibilità ====
==== Non compatibilità ====
-
{{
 
-
#if: ONLY | {{
 
-
  #switch: {{
 
-
      #if:  | {{{5}}} | {{
 
-
        #if:  | {{{4}}} | {{
 
-
            #if:  | {{{3}}} | {{
 
-
              #if: {{Codename|Oldstable}} | {{Codename|Oldstable}} | ONLY
 
-
            }}
 
-
        }}
 
-
      }}
 
-
  }} | Woody | Sarge | Etch | Lenny | Squeeze | Testing_{{#expr: {{CURRENTYEAR}} + 1}} | Unstable_{{#expr: {{CURRENTYEAR}} + 1}} | Testing_{{CURRENTYEAR}} | Unstable_{{CURRENTYEAR}} | Testing_{{#expr: {{CURRENTYEAR}} - 1}} | Unstable_{{#expr: {{CURRENTYEAR}} - 1}} | Testing_{{#expr: {{CURRENTYEAR}} - 2}} | Unstable_{{#expr: {{CURRENTYEAR}} - 2}} | Testing_{{#expr: {{CURRENTYEAR}} - 3}} | Unstable_{{#expr: {{CURRENTYEAR}} - 3}} =
 
-
  | Testing_{{#expr: {{CURRENTYEAR}} - 4}} | Unstable_{{#expr: {{CURRENTYEAR}} - 4}} | Testing_{{#expr: {{CURRENTYEAR}} - 5}} | Unstable_{{#expr: {{CURRENTYEAR}} - 5}} = {{
 
-
      #ifeq: ONLY | ONLY |  | {{Guida da controllare|AUTO}}
 
-
  }}
 
-
  | {{
 
-
      #switch: {{Codename|Stable}} | ONLY | {{Codename|Oldstable}} |  |  |  =
 
-
      | {{
 
-
        #switch: {{Codename|Oldstable}} | ONLY | {{Codename|Oldstable}} |  |  |  =
 
-
        | {{
 
-
            #switch: {{Codename|Oldoldstable}} | ONLY | {{Codename|Oldstable}} |  |  |  = {{
 
-
              #ifeq: ONLY | ONLY |  | {{Guida da controllare|AUTO}}
 
-
            }} | {{
 
-
              #ifeq: ONLY | ONLY |  | {{Guida da controllare|AUTO|NOCATEGORY}}
 
-
            }} [[Categoria:Guide abbandonate]]
 
-
        }}
 
-
      }}
 
-
  }}
 
-
}} |
 
-
}}
 
{|style="float:right; clear:both; width:23%; min-width:133px; margin:0 0 10px 8px; padding-bottom:5px; border-radius:0.5em; border:1px solid #4e88d0; background-color:#f8fbfd; font-variant:small-caps; text-align:center;"
{|style="float:right; clear:both; width:23%; min-width:133px; margin:0 0 10px 8px; padding-bottom:5px; border-radius:0.5em; border:1px solid #4e88d0; background-color:#f8fbfd; font-variant:small-caps; text-align:center;"
-
|[[Image:Debian-swirl.png|33px|link=]] '''Versioni Compatibili''' {{
+
|[[Image:Debian-swirl.png|33px|link=]] '''Versioni Compatibili''' <br /> '''soltanto:''' {{#ifeq: {{Codename|Oldstable}} | {{Codename|Stable}} | [[Categoria: Guide compatibili con stable]] | }}{{
-
#ifeq: ONLY | ONLY | <br />'''soltanto:''' |  }}{{
+
#switch: {{Codename|Oldstable}}
-
#if: ONLY | {{Versioni compatibili elenco|ONLY}}{{
+
| ONLY =
-
  #if: {{Codename|Oldstable}} | {{Versioni compatibili elenco|{{Codename|Oldstable}}}}
+
| Woody = <br />Debian 3.0 "Woody"
-
}}{{
+
| Sarge = <br />Debian 3.1 "Sarge"
-
  #if: | {{Versioni compatibili elenco|{{{3}}}}}
+
| Etch = <br />Debian 4 "Etch"
-
}}{{
+
| Lenny = <br />Debian 5 "Lenny"
-
  #if: | {{Versioni compatibili elenco|{{{4}}}}}
+
| Squeeze = <br />Debian 6 "Squeeze"
-
}}{{
+
| Wheezy = <br />Debian 7 "Wheezy"
-
  #if: | {{Versioni compatibili elenco|{{{5}}}}}
+
| Jessie = <br />Debian 8 "Jessie"
-
}}{{
+
| Stretch = <br />Debian 9 "Stretch"
-
  #if: | <br />ERRORE: Consentiti fino a 5 parametri! [[Categoria: Errori nel template Versioni compatibili]] |
+
| Buster = <br />Debian 10 "Buster"
-
}} | <br />Tutte le versioni supportate di Debian [[Categoria: Guide compatibili con tutte le versioni di Debian]] }}{{
+
| Testing_{{CURRENTYEAR}} | Testing_{{#expr: {{CURRENTYEAR}} - 1}} | Testing_{{#expr: {{CURRENTYEAR}} + 1}} = <br/>Debian testing "{{Codename|Testing}}" [[Categoria: Guide compatibili con testing]]
-
#ifeq: ONLY | ONLY | | {{
+
| Testing_{{#expr: {{CURRENTYEAR}} - 2}} | Testing_{{#expr: {{CURRENTYEAR}} - 3}} | Testing_{{#expr: {{CURRENTYEAR}} - 4}} | Testing_{{#expr: {{CURRENTYEAR}} - 5}} | Testing_{{#expr: {{CURRENTYEAR}} - 6}} | Testing_{{#expr: {{CURRENTYEAR}} - 7}} | Testing_{{#expr: {{CURRENTYEAR}} - 8}} | Testing_{{#expr: {{CURRENTYEAR}} - 9}} | Testing_{{#expr: {{CURRENTYEAR}} - 10}} = <br/>Debian testing (non recente) [[Categoria: Guide compatibili con testing (non recenti)]]
-
  #switch: {{Codename|Oldstable}} | ONLY | {{Codename|Oldstable}} | |  |  = {{
+
| Unstable_{{CURRENTYEAR}} | Unstable_{{#expr: {{CURRENTYEAR}} - 1}} | Unstable_{{#expr: {{CURRENTYEAR}} + 1}} = <br />Debian "Sid" [[Categoria: Guide compatibili con Sid]]
-
      #switch: {{Codename|Stable}} | ONLY | {{Codename|Oldstable}} | | | =  
+
| Unstable_{{#expr: {{CURRENTYEAR}} - 2}} | Unstable_{{#expr: {{CURRENTYEAR}} - 3}} | Unstable_{{#expr: {{CURRENTYEAR}} - 4}} | Unstable_{{#expr: {{CURRENTYEAR}} - 5}} | Unstable_{{#expr: {{CURRENTYEAR}} - 6}} | Unstable_{{#expr: {{CURRENTYEAR}} - 7}} | Unstable_{{#expr: {{CURRENTYEAR}} - 8}} | Unstable_{{#expr: {{CURRENTYEAR}} - 9}} | Unstable_{{#expr: {{CURRENTYEAR}} - 10}} = <br/>Debian "Sid" (non recente) [[Categoria: Guide compatibili con Sid (non recenti)]]
-
      | <br />[[:Categoria:Guide non compatibili con stable|Verificala con {{Codename|Stable}}]] [[Categoria: Guide non compatibili con stable]] }}
+
| {{Codename|Testing}} | Testing = <br />ERRORE: utilizzare "Testing_{{CURRENTYEAR}}" come parametro al posto di "{{Codename|Oldstable}}"! Vedi [[Template:Versioni compatibili|qui]]. [[Categoria: Errori nel template Versioni compatibili]]
-
}}
+
| Sid | Unstable = <br />ERRORE: utilizzare "Unstable_{{CURRENTYEAR}}" come parametro al posto di "{{Codename|Oldstable}}"! Vedi [[Template:Versioni compatibili|qui]]. [[Categoria: Errori nel template Versioni compatibili]]
 +
| <br />ERRORE: valore non valido ({{Codename|Oldstable}})! Vedi [[Template:Versioni compatibili|qui]]. [[Categoria: Errori nel template Versioni compatibili]]
}}
}}
|}
|}
Riga 208: Riga 171:
=== Nessun parametro ===
=== Nessun parametro ===
-
{{
 
-
#if:  | {{
 
-
  #switch: {{
 
-
      #if:  | {{{5}}} | {{
 
-
        #if:  | {{{4}}} | {{
 
-
            #if:  | {{{3}}} | {{
 
-
              #if:  | {{{2}}} | {{{1}}}
 
-
            }}
 
-
        }}
 
-
      }}
 
-
  }} | Woody | Sarge | Etch | Lenny | Squeeze | Testing_{{#expr: {{CURRENTYEAR}} + 1}} | Unstable_{{#expr: {{CURRENTYEAR}} + 1}} | Testing_{{CURRENTYEAR}} | Unstable_{{CURRENTYEAR}} | Testing_{{#expr: {{CURRENTYEAR}} - 1}} | Unstable_{{#expr: {{CURRENTYEAR}} - 1}} | Testing_{{#expr: {{CURRENTYEAR}} - 2}} | Unstable_{{#expr: {{CURRENTYEAR}} - 2}} | Testing_{{#expr: {{CURRENTYEAR}} - 3}} | Unstable_{{#expr: {{CURRENTYEAR}} - 3}} =
 
-
  | Testing_{{#expr: {{CURRENTYEAR}} - 4}} | Unstable_{{#expr: {{CURRENTYEAR}} - 4}} | Testing_{{#expr: {{CURRENTYEAR}} - 5}} | Unstable_{{#expr: {{CURRENTYEAR}} - 5}} = {{
 
-
      #ifeq:  | ONLY |  | {{Guida da controllare|AUTO}}
 
-
  }}
 
-
  | {{
 
-
      #switch: {{Codename|Stable}} |  |  |  |  |  =
 
-
      | {{
 
-
        #switch: {{Codename|Oldstable}} |  |  |  |  |  =
 
-
        | {{
 
-
            #switch: {{Codename|Oldoldstable}} |  |  |  |  |  = {{
 
-
              #ifeq:  | ONLY |  | {{Guida da controllare|AUTO}}
 
-
            }} | {{
 
-
              #ifeq:  | ONLY |  | {{Guida da controllare|AUTO|NOCATEGORY}}
 
-
            }} [[Categoria:Guide abbandonate]]
 
-
        }}
 
-
      }}
 
-
  }}
 
-
}} |
 
-
}}
 
{|style="float:right; clear:both; width:23%; min-width:133px; margin:0 0 10px 8px; padding-bottom:5px; border-radius:0.5em; border:1px solid #4e88d0; background-color:#f8fbfd; font-variant:small-caps; text-align:center;"
{|style="float:right; clear:both; width:23%; min-width:133px; margin:0 0 10px 8px; padding-bottom:5px; border-radius:0.5em; border:1px solid #4e88d0; background-color:#f8fbfd; font-variant:small-caps; text-align:center;"
-
|[[Image:Debian-swirl.png|33px|link=]] '''Versioni Compatibili''' {{
+
|[[Image:Debian-swirl.png|33px|link=]] '''Versioni Compatibili''' <br /> Tutte le versioni supportate di Debian
-
#ifeq:  | ONLY | <br />'''soltanto:''' |  }}{{
+
-
#if:  | {{Versioni compatibili elenco|{{{1}}}}}{{
+
-
  #if:  | {{Versioni compatibili elenco|{{{2}}}}}
+
-
}}{{
+
-
  #if:  | {{Versioni compatibili elenco|{{{3}}}}}
+
-
}}{{
+
-
  #if:  | {{Versioni compatibili elenco|{{{4}}}}}
+
-
}}{{
+
-
  #if:  | {{Versioni compatibili elenco|{{{5}}}}}
+
-
}}{{
+
-
  #if:  | <br />ERRORE: Consentiti fino a 5 parametri! [[Categoria: Errori nel template Versioni compatibili]] |
+
-
}} | <br />Tutte le versioni supportate di Debian [[Categoria: Guide compatibili con tutte le versioni di Debian]] }}{{
+
-
#ifeq:  | ONLY |  | {{
+
-
  #switch: {{Codename|Oldstable}} |  |  |  |  |  = {{
+
-
      #switch: {{Codename|Stable}} |  |  |  |  |  =
+
-
      | <br />[[:Categoria:Guide non compatibili con stable|Verificala con {{Codename|Stable}}]] [[Categoria: Guide non compatibili con stable]]  }}
+
-
}}
+
-
}}
+
|}
|}
Se non vengono aggiunti parametri, la guida è compatibile con tutte le versioni supportate di Debian.
Se non vengono aggiunti parametri, la guida è compatibile con tutte le versioni supportate di Debian.

Versione delle 17:47, 21 set 2019

Introduzione

Questo template permette di segnalare le versioni di Debian compatibili con una guida, e il suo uso è obbligatorio per tutte le guide relative a questo sistema operativo. È preferibile che le versioni elencate siano solo quelle per cui la guida è stata esplicitamente testata, o in alternativa che contengono le stesse versioni dei pacchetti trattati.

Per le guide divise in più pagine è raccomandata l'inclusione del template soltanto nella principale.

Uso

Parametri

Debian-swirl.png Versioni Compatibili
Debian 9 "Stretch"
Debian 10 "Buster"

Aggiungere un parametro per ogni versione compatibile, separati tra loro da un carattere "|". Il nome da inserire è il codename di Debian, ovvero il nome del personaggio di Toy Story a cui la versione specifica è dedicata. La lista completa è riportata in seguito.

Si noti che tutti i pacchetti presenti in testing e unstable possono ricevere aggiornamenti che ne alterano le funzionalità, oppure essere rimossi durante la fase di freeze o prima ancora, motivo per cui in questo template si è scelto di prediligere la compatibilità per l'attuale stable e versioni precedenti di Debian. Per garantire in futuro che tutte le guide verificate per "Bullseye" siano testate per quella che sarà la versione stable rilasciata, si riservano i codename per le sole versioni stable e precedenti di Debian, mentre per le più recenti si utilizzano la suite e l'ultimo anno di verifica.

Per esempio:

{{Versioni compatibili|Stretch|Buster}}

Oppure con Buster, testing (Bullseye) e unstable/Sid:

{{Versioni compatibili|Buster|Testing_2019|Unstable_2019}}

Numero massimo di parametri: 5

Codename ammessi (per Debian stable e precedenti):

Suite ammesse (per testing e Sid):

Se si supera il numero massimo di parametri ammessi, è possibile rimuovere le versioni non più supportate. Essendo permessi fino a 5 parametri, è sempre possibile indicare la compatibilità per le attuali LTS, oldstable, stable, testing e unstable/Sid.

Per testing e unstable, si deve utilizzare sempre soltanto un singolo parametro, quello relativo all'ultimo anno di revisione, aggiornandolo quando si effettua una nuova revisione per la stessa versione o rimuovendolo se si considera ormai obsoleta.

I parametri del template inoltre devono essere ordinati per versione, partendo dalla meno recente (ordine crescente).

Non compatibilità

Debian-swirl.png Versioni Compatibili
soltanto:
Debian 9 "Stretch"

Utilizzando la stringa ONLY come primo parametro, è possibile utilizzare questo template per segnalare che soltanto le versioni esplicitamente elencate con i parametri successivi sono supportate.

Si consideri che il limite di cinque parametri è ancora valido, e pertanto soltanto altri quattro parametri sono possibili, scegliendoli tra gli stessi ammessi nella sezione precedente.

Tali guide, quando contengono soltanto l'attuale oldstable, saranno anche rimosse dall'elenco di quelle da verificare con la versione stable corrente di Debian.

Per esempio:

{{Versioni compatibili|ONLY|Stretch}}

Inoltre una guida segnalata esplicitamente come non compatibile per altre versioni può diventare obsoleta, ma non da controllare o da adottare.

Nessun parametro

Debian-swirl.png Versioni Compatibili
Tutte le versioni supportate di Debian

Se non vengono aggiunti parametri, la guida è compatibile con tutte le versioni supportate di Debian.

Per "versioni supportate" si intendono tutte le seguenti: LTS, oldstable, stable, testing e unstable/Sid.

È sconsigliata questa forma, salvo si tratti di guide teoriche o per pacchetti base del sistema (Priorità del pacchetto: required, important o standard), in quanto la compatibilità della guida non è tracciabile in automatico dalle categorie nascoste. Pertanto le guide non solo teoriche, che non sono più relative a pacchetti base del sistema al rilascio della nuova versione stable di Debian, possono essere modificate per aggiungere al template soltanto le versioni precedenti.

Per esempio:

{{Versioni compatibili}}

Limitatamente per le guide segnalate come compatibili per tutte le versioni, allo scopo di evitare di doverle aggiornare a ogni nuovo rilascio di Debian in caso si faccia riferimento ai codename dell'attuale stable, testing, ecc... e si debbano modificare solo quelli, oppure se si voglia utilizzare sempre l'attuale mirror di default per i repository, sono disponibili due template di supporto:

Ciò ne consentirà un aggiornamento automatico, limitatamente alle informazioni ottenute dai template.

Categorie nascoste

Questo template associa in automatico delle categorie, per poter trovare rapidamente le guide compatibili con una data versione:

Oppure, se viene utilizzato questo template con dei parametri, per permettere la ricerca in base alla mancanza di verifiche:

Per finire le guide contenenti errori con questo template sono rintracciabili in questa categoria.

Strumenti personali
Namespace
Varianti
Azioni
Navigazione
Risorse
Strumenti