Repository ufficiali

Da Guide@Debianizzati.Org.

(Differenze fra le revisioni)
(Oldoldstable (la stable obsoleta ancora precedente): Debian Squeeze: fine supporto Squeeze LTS)
(task Revisione Wiki #61)
Riga 14: Riga 14:
}}
}}
-
== [[Stable]]: Debian [[Jessie]] ==
+
== [[Stable]]: Debian {{Codename|versione_stable}} ([[{{Codename|Stable}}]]) ==
-
<pre>
+
# Debian {{Codename|versione_stable}} ({{Codename|Stable}})
-
# Debian Stable (Jessie)
+
deb <nowiki>http://ftp.it.debian.org/debian/</nowiki> {{Codename|stable}} main
-
deb http://ftp.it.debian.org/debian/ jessie main
+
deb-src <nowiki>http://ftp.it.debian.org/debian/</nowiki> {{Codename|stable}} main
-
deb-src http://ftp.it.debian.org/debian/ jessie main
+
-
 
+
# Aggiornamenti della sicurezza (circa 3 anni di supporto dal rilascio avvenuto il {{Codename|datarilascio_stable}})
-
# Aggiornamenti della sicurezza
+
deb <nowiki>http://security.debian.org/</nowiki> {{Codename|stable}}/updates main
-
deb http://security.debian.org/ jessie/updates main
+
deb-src <nowiki>http://security.debian.org/</nowiki> {{Codename|stable}}/updates main
-
deb-src http://security.debian.org/ jessie/updates main
+
-
</pre>
+
File release di questo repository: [http://ftp.it.debian.org/debian/dists/stable/Release Release]
File release di questo repository: [http://ftp.it.debian.org/debian/dists/stable/Release Release]
Riga 31: Riga 29:
Mentre per avere pacchetti più aggiornati, si possono usare i [[Il repository Backports|backports]].
Mentre per avere pacchetti più aggiornati, si possono usare i [[Il repository Backports|backports]].
-
== [[Testing]]: Debian [[Stretch]] ==
+
== [[Testing]]: Debian "[[{{Codename|Testing}}]]" ==
-
<pre>
+
# Debian {{Codename|versione_testing}} ({{Codename|Testing}})
-
# Debian Testing (Stretch)
+
deb <nowiki>http://ftp.it.debian.org/debian/</nowiki> {{Codename|testing}} main
-
deb http://ftp.it.debian.org/debian/ stretch main
+
deb-src <nowiki>http://ftp.it.debian.org/debian/</nowiki> {{Codename|testing}} main
-
deb-src http://ftp.it.debian.org/debian/ stretch main
+
 +
# Aggiornamenti della sicurezza
 +
deb <nowiki>http://security.debian.org/</nowiki> {{Codename|testing}}/updates main
 +
deb-src <nowiki>http://security.debian.org/</nowiki> {{Codename|testing}}/updates main
-
# Aggiornamenti della sicurezza
 
-
deb http://security.debian.org/ stretch/updates main
 
-
deb-src http://security.debian.org/ stretch/updates main
 
-
</pre>
 
File release di questo repository: [http://ftp.it.debian.org/debian/dists/testing/Release Release]
File release di questo repository: [http://ftp.it.debian.org/debian/dists/testing/Release Release]
Riga 48: Riga 45:
-->
-->
<pre>
<pre>
-
# Debian Unstable (Sid)
+
# Debian unstable (Sid)
-
deb http://ftp.it.debian.org/debian/ unstable main
+
deb http://ftp.it.debian.org/debian/ sid main
-
deb-src http://ftp.it.debian.org/debian/ unstable main
+
deb-src http://ftp.it.debian.org/debian/ sid main
</pre>
</pre>
-
Per '''Sid''' non c'è il repository per la sicurezza dato che eventuali falle vengono corrette semplicemente con l'aggiornamento del pacchetto incriminato.<br/>
+
Per '''Sid''' non c'è il repository per la sicurezza dato che eventuali falle vengono corrette semplicemente con l'aggiornamento del pacchetto incriminato.
 +
 
File release di questo repository: [http://ftp.it.debian.org/debian/dists/sid/Release Release]
File release di questo repository: [http://ftp.it.debian.org/debian/dists/sid/Release Release]
 +
== [[Oldstable]] (la vecchia stable): Debian {{Codename|versione_oldstable}} ([[{{Codename|Oldstable}}]]) ==
 +
{{Warningbox|Il supporto per Debian {{Codename|Oldstable}} termina circa tre anni dopo il suo rilascio, avvenuto il {{Codename|datarilascio_oldstable}}. A partire da quella data non saranno più presenti gli aggiornamenti dei pacchetti per la correzione di eventuali bug di sicurezza. Prima di tale data è vivamente consigliato di effettuare un [[avanzamento di versione]] o di aggiungere il repository per il [[LTS|supporto a lungo termine]].}}
 +
# Debian {{Codename|versione_oldstable}} ({{Codename|Oldstable}})
 +
deb <nowiki>http://ftp.it.debian.org/debian/</nowiki> {{Codename|oldstable}} main
 +
deb-src <nowiki>http://ftp.it.debian.org/debian/</nowiki> {{Codename|oldstable}} main
 +
 +
# Aggiornamenti della sicurezza (circa 3 anni di supporto dal rilascio avvenuto il {{Codename|datarilascio_oldstable}})
 +
deb <nowiki>http://security.debian.org/</nowiki> {{Codename|oldstable}}/updates main
 +
deb-src <nowiki>http://security.debian.org/</nowiki> {{Codename|oldstable}}/updates main
-
== [[Old Stable|Oldstable]] (la vecchia stable): Debian [[Wheezy]] ==
 
-
{{Warningbox|Il supporto per Debian 7.0 "Wheezy" terminerà circa un anno dopo il rilascio di Debian 8.0 "Jessie" (25 aprile 2015). A partire da quella data non saranno più presenti gli aggiornamenti dei pacchetti per la correzione di eventuali bug. Prima di tale data è vivamente consigliato di aggiornare il sistema a Debian 8.0 "Jessie" o di aggiungere il repository per il [[LTS|supporto a lungo termine]], che lo estenderà per altri due anni per i pacchetti principali.}}
 
-
<pre>
 
-
# Debian oldstable (Wheezy)
 
-
deb http://ftp.it.debian.org/debian/ wheezy main
 
-
deb-src http://ftp.it.debian.org/debian/ wheezy main
 
-
 
-
# Aggiornamenti della sicurezza
 
-
deb http://security.debian.org/ wheezy/updates main
 
-
deb-src http://security.debian.org/ wheezy/updates main
 
-
</pre>
 
File release di questo repository: [http://ftp.it.debian.org/debian/dists/oldstable/Release Release]
File release di questo repository: [http://ftp.it.debian.org/debian/dists/oldstable/Release Release]
-
== Oldoldstable (la stable obsoleta ancora precedente): Debian Squeeze ==
+
== Oldoldstable (la stable obsoleta ancora precedente): Debian {{Codename|versione_oldoldstable}} ({{Codename|Oldoldstable}}) ==
-
{{Warningbox|Il supporto per Debian 6.0 "Squeeze" è terminato il 4 maggio 2014, quindi non ci sono più aggiornamenti dei pacchetti per la correzione di eventuali bug, e anche il [[LTS|supporto a lungo termine]] per i pacchetti principali e le principali architetture è terminato il 29 febbraio 2016.}}
+
{{Warningbox|'''Non esiste più alcun supporto ufficiale''' ed è quindi inutile aggiungere i repository per gli aggiornamenti di sicurezza. È pertanto '''caldamente consigliato di programmare una nuova installazione''' di Debian [[stable]] ([[{{Codename|Stable}}]]), oppure in alternativa un duplice [[avanzamento di versione]] (alla [[oldstable]] e poi infine all'attuale [[stable]]), in modo da completarla prima che termini anche l'eventuale [[LTS|supporto a lungo termine]], circa 5 anni dopo il suo rilascio, avvenuto il {{Codename|datarilascio_oldoldstable}}.}}
-
<pre>
+
# Debian {{Codename|versione_oldoldstable}} ({{Codename|Oldoldstable}})
-
# Debian oldoldstable (Squeeze)
+
deb <nowiki>http://ftp.it.debian.org/debian/</nowiki> {{Codename|oldoldstable}} main
-
deb http://ftp.it.debian.org/debian/ squeeze main
+
deb-src <nowiki>http://ftp.it.debian.org/debian/</nowiki> {{Codename|oldoldstable}} main
-
deb-src http://ftp.it.debian.org/debian/ squeeze main
+
-
# Aggiornamenti della sicurezza
 
-
deb http://security.debian.org/ squeeze/updates main
 
-
deb-src http://security.debian.org/ squeeze/updates main
 
-
</pre>
 
File release di questo repository: [http://ftp.it.debian.org/debian/dists/oldoldstable/Release Release]
File release di questo repository: [http://ftp.it.debian.org/debian/dists/oldoldstable/Release Release]
Riga 86: Riga 77:
|Verificata_da=
|Verificata_da=
:[[Utente:S3v|S3v]] 15:49, 22 ago 2014 (CEST)
:[[Utente:S3v|S3v]] 15:49, 22 ago 2014 (CEST)
-
:[[Utente:HAL 9000|HAL 9000]] 13:01, 29 apr 2015 (CEST)
 
:[[Utente:Wtf|Wtf]] 21:07, 11 mag 2015 (CEST)
:[[Utente:Wtf|Wtf]] 21:07, 11 mag 2015 (CEST)
:[[Utente:Spoon|Spoon]] 19:29, 14 dic 2015 (CET)
:[[Utente:Spoon|Spoon]] 19:29, 14 dic 2015 (CET)
 +
:[[Utente:HAL 9000|HAL 9000]] 14:45, 8 apr 2016 (CEST)
|Numero_revisori=4
|Numero_revisori=4
}}
}}
[[Categoria: Repository ufficiali]]
[[Categoria: Repository ufficiali]]

Versione delle 13:45, 8 apr 2016

I repository
Arrow left.png

Introduzione ai repository

Repository ufficiali di Debian

Repository esterni

Extra

Arrow right.png



Debian-swirl.png Versioni Compatibili
Tutte le versioni supportate di Debian

Indice

Lista repository ufficiali Debian

Di seguito troverete l'elenco dei repository ufficiali da inserire nel file /etc/apt/sources.list per le varie versioni di Debian. Il mirror è quello italiano.

Per ulteriori informazioni leggere la sezione: Sources.list.

Info.png Nota
  • In questa guida si danno per scontate le nozioni di base riguardo il funzionamento di Debian, e dei repository in particolare.
  • I repository qui indicati possiedono tutte e tre le sezioni ufficiali, cioè main, contrib e non-free, tuttavia nei seguenti esempi si indicherà solo main.


Stable: Debian 10 (Buster)

# Debian 10 (Buster)
deb http://ftp.it.debian.org/debian/ buster main
deb-src http://ftp.it.debian.org/debian/ buster main

# Aggiornamenti della sicurezza (circa 3 anni di supporto dal rilascio avvenuto il 6 luglio 2019)
deb http://security.debian.org/ buster/updates main
deb-src http://security.debian.org/ buster/updates main

File release di questo repository: Release

Per aggiornamenti raccomandati non legati alla sicurezza si possono aggiungere gli updates (vedere Repository speciali).

Mentre per avere pacchetti più aggiornati, si possono usare i backports.

Testing: Debian "Bullseye"

# Debian 11 (Bullseye)
deb http://ftp.it.debian.org/debian/ bullseye main
deb-src http://ftp.it.debian.org/debian/ bullseye main

# Aggiornamenti della sicurezza
deb http://security.debian.org/ bullseye/updates main
deb-src http://security.debian.org/ bullseye/updates main

File release di questo repository: Release

Unstable: Debian Sid

# Debian unstable (Sid)
deb http://ftp.it.debian.org/debian/ sid main
deb-src http://ftp.it.debian.org/debian/ sid main

Per Sid non c'è il repository per la sicurezza dato che eventuali falle vengono corrette semplicemente con l'aggiornamento del pacchetto incriminato.

File release di questo repository: Release

Oldstable (la vecchia stable): Debian 9 (Stretch)

Warning.png ATTENZIONE
Il supporto per Debian Stretch termina circa tre anni dopo il suo rilascio, avvenuto il 17 giugno 2017. A partire da quella data non saranno più presenti gli aggiornamenti dei pacchetti per la correzione di eventuali bug di sicurezza. Prima di tale data è vivamente consigliato di effettuare un avanzamento di versione o di aggiungere il repository per il supporto a lungo termine.


# Debian 9 (Stretch)
deb http://ftp.it.debian.org/debian/ stretch main
deb-src http://ftp.it.debian.org/debian/ stretch main

# Aggiornamenti della sicurezza (circa 3 anni di supporto dal rilascio avvenuto il 17 giugno 2017)
deb http://security.debian.org/ stretch/updates main
deb-src http://security.debian.org/ stretch/updates main

File release di questo repository: Release

Oldoldstable (la stable obsoleta ancora precedente): Debian 8 (Jessie)

Warning.png ATTENZIONE
Non esiste più alcun supporto ufficiale ed è quindi inutile aggiungere i repository per gli aggiornamenti di sicurezza. È pertanto caldamente consigliato di programmare una nuova installazione di Debian stable (Buster), oppure in alternativa un duplice avanzamento di versione (alla oldstable e poi infine all'attuale stable), in modo da completarla prima che termini anche l'eventuale supporto a lungo termine, circa 5 anni dopo il suo rilascio, avvenuto il 25 aprile 2015.


# Debian 8 (Jessie)
deb http://ftp.it.debian.org/debian/ jessie main
deb-src http://ftp.it.debian.org/debian/ jessie main

File release di questo repository: Release




Guida scritta da: Risca86

Swirl-auth100.png Guida Debianized

Estesa da:
Verificata da:
S3v 15:49, 22 ago 2014 (CEST)
Wtf 21:07, 11 mag 2015 (CEST)
Spoon 19:29, 14 dic 2015 (CET)
HAL 9000 14:45, 8 apr 2016 (CEST)

Verificare ed estendere la guida | Cos'è una guida Debianized

Strumenti personali
Namespace
Varianti
Azioni
Navigazione
Risorse
Strumenti