Installare Adobe Flash Player

Da Guide@Debianizzati.Org.

(Differenze fra le revisioni)
m (PepperFlashPlayer)
m (compatibilità come da ultima verifica (software non di sistema))
(9 revisioni intermedie non mostrate.)
Riga 1: Riga 1:
{{Non-free|Un'alternativa completamente libera è [[Gnash]].}}
{{Non-free|Un'alternativa completamente libera è [[Gnash]].}}
-
{{Versioni compatibili|Wheezy|Jessie|Testing_2016|Unstable_2016}}
+
{{Versioni compatibili|Stretch}}
__TOC__
__TOC__
-
{{Box | Nota | Il 22 febbraio 2012 Adobe ha annunciato che il plugin Flash per Linux non verrà più aggiornato a nuove versioni. Per i successivi cinque anni dalla data indicata, cioè sino al 2017, saranno rilasciati esclusivamente aggiornamenti di sicurezza.}}
+
{{Box | Nota | Da dicembre 2016 sul sito di Adobe è disponibile il plugin Flash per Linux aggiornato a nuove versioni esattamente come avviene per altri sistemi operativi (Windows e Mac). Il plugin non supporta tutte le caratteristiche implementate in PepperFlashPlayer.}}
== Copyright ==
== Copyright ==
-
Il plugin Adobe Flash Player è un software proprietario. All'atto della sua installazione compare questo avvertimento:
+
Il plugin Adobe Flash Player è un software proprietario. Nella pagina descrittiva del pacchetto {{deb|flashplugin-nonfree}} è presente questo avvertimento:
-
<pre>
+
<blockquote>
-
WARNING: Installing this Debian package causes the Adobe Flash Player to be downloaded from www.adobe.com.
+
''WARNING: Installing this Debian package causes the Adobe Flash Player to be downloaded from www.adobe.com. The End User License Agreement of the Adobe Flash Player is available at www.adobe.com.''
-
The End User License Agreement of the Adobe Flash Player is available at www.adobe.com.
+
</blockquote>
-
</pre>
+
L'avviso informa che il pacchetto scaricherà il plugin direttamente dal sito di Adobe e che l'accordo di licenza per l'utente finale è disponibile sul medesimo sito.
== Installazione da repository==
== Installazione da repository==
-
Da Wheezy e successive sia a 32 che 64 bit è sufficiente abilitare la [[sezione]] '''contrib''' del [[repository]] ufficiale Debian. Quindi si lancino i comandi:
+
{{Warningbox|Da gennaio 2017 è impossibile installare il plugin flash tramite il pacchetto ''flashplugin-nonfree'' presente nei repository Debian. È necessario intervenire tramite installazione manuale.}}
 +
Nel caso sul sistema in uso sia presente una vecchia installazione del pacchetto ''flashplugin-nonfree'' prelevato dai repository Debian, procedere con la sua disinstallazione poi proseguire con l'installazione manuale.
 +
 +
<!--
 +
Da [[Wheezy]] e successive è sufficiente abilitare la [[sezione]] '''contrib''' del [[repository]] ufficiale Debian e da terminale impartire i seguenti comandi
<pre>
<pre>
# apt-get update
# apt-get update
Riga 25: Riga 29:
# update-flashplugin-nonfree --install
# update-flashplugin-nonfree --install
</pre>
</pre>
 +
-->
 +
=== Disinstallazione pacchetto ===
 +
Eseguire i seguenti comandi:
 +
<pre># update-flashplugin-nonfree --uninstall</pre>
 +
e successivamente
 +
<pre># apt-get remove flashplugin-nonfree</pre>
== Installazione manuale ==
== Installazione manuale ==
-
Per l'installazione manuale dell'ultima versione, occorre scaricare il ''file .tar.gz per Linux'' dalla pagina ufficiale<sup>[[#Link esterni|[1]]]</sup> di Adobe ed estrarre il file ''libflashplayer.so'' all'interno della directory dei plugin.
+
Per l'installazione manuale dell'ultima versione, occorre scaricare il pacchetto per Linux ''.tar.gz'' '''NPAPI''' adatto alla propria architettura (32 o 64 bit) dalla pagina ufficiale<sup>[[#Link esterni|[1]]]</sup> di Adobe ed estrarre il file '''<code>libflashplayer.so</code>''' all'interno della directory dei plugin.
La directory dei plugin varia a seconda dei browser o delle direttive che indichiamo nel browser per la ricerca dei plugin. Se non esiste va creata.
La directory dei plugin varia a seconda dei browser o delle direttive che indichiamo nel browser per la ricerca dei plugin. Se non esiste va creata.
-
 
Alcune delle posizioni dei browser più comuni, sempre che al browser non sia indicata una direttiva specifica.
Alcune delle posizioni dei browser più comuni, sempre che al browser non sia indicata una direttiva specifica.
Riga 43: Riga 52:
* per comodità è possibile estrarre il file ''libflashplayer.so'' in una directory a nostro piacimento e creare all'interno delle directory dei plugin dei link simbolici che puntino ad esso;
* per comodità è possibile estrarre il file ''libflashplayer.so'' in una directory a nostro piacimento e creare all'interno delle directory dei plugin dei link simbolici che puntino ad esso;
* se non si ha un sistema multiutenza si può scegliere di creare la directory <code>~/.mozilla/plugins/</code> e inserirvi il file ''libflashplayer.so''.}}
* se non si ha un sistema multiutenza si può scegliere di creare la directory <code>~/.mozilla/plugins/</code> e inserirvi il file ''libflashplayer.so''.}}
-
=== Aggiornamento ===
+
 
-
Per aggiornare la versione del plugin, occorre scaricare la nuova versione dal sito ufficiale ed estrarre il nuovo ''libflashplayer.so'' dove indicato in precedenza.
+
=== Aggiornamento manuale ===
 +
Per aggiornare la versione del plugin, occorre scaricare la nuova versione dal sito ufficiale. Una volta scompattato il pacchetto, posizionare il nuovo ''libflashplayer.so'' come indicato in precedenza.
Riga 51: Riga 61:
== Pulizia cache ==
== Pulizia cache ==
-
Il player di flash lascia traccia della nostra navigazione, per maggiori informazioni questa<sup>[[#Link esterni|[3]]]</sup>  discussione sul forum di Debianizzati.
+
Il player di flash lascia traccia della nostra navigazione, per maggiori informazioni consultare questa<sup>[[#Link esterni|[3]]]</sup>  discussione sul forum di Debianizzati.
Per maggiore sicurezza è consigliabile creare ed eseguire periodicamente uno script che chiameremo '''cleanflash.sh''', e al cui interno inseriremo:
Per maggiore sicurezza è consigliabile creare ed eseguire periodicamente uno script che chiameremo '''cleanflash.sh''', e al cui interno inseriremo:
Riga 71: Riga 81:
-
== PepperFlashPlayer ==
+
== Pepper Flash Player ==
-
È un plugin proprietario sviluppato da Google, funzionante solamente sui browser: Chrome, Chromium dalla versione 34 (e altri basati su questo) e Opera dalla versione 26.x.<br />
+
È un plugin proprietario sviluppato da Google, utilizza le [[Api|API]] [[PPAPI]], funziona solamente sui browser: Chrome, Chromium dalla versione 34 (e altri basati su questo) e Opera dalla versione 26.x.<br />
-
Mentre il plugin Flash di Adobe fornisce attualmente solo aggiornamenti di sicurezza per Linux, PepperFlash Player integra le versioni aggiornate rilasciate per altri Sistemi e offre nuove funzionalità (ad esempio utilizza le [[Api|API]] [[PPAPI]].
+
Pepper Flash Player integra le versioni aggiornate rilasciate da Adobe Flash Player e offre funzionalità non presenti in quest'ultimo.
 +
 
 +
<!--
=== Installazione da repository ===
=== Installazione da repository ===
-
'''N.B.''' solo sistemi a 64 bit
+
Il pacchetto ha una funzione simile a quella prevista per il plugin di Adobe Flash, scarica il browser Chrome direttamente da Google per poi procedere con la sola estrazione del plugin Pepper Flash.
 +
Attualmente disponibile solo per architetture a 64 bit nei repository ''wheezy-backports'' e ''Jessie''.
Per installare PepperFlashPlayer è necessario abilitare la sezione '''contrib''' del [[repository]] ufficiale Debian e impartire i seguenti comandi:
Per installare PepperFlashPlayer è necessario abilitare la sezione '''contrib''' del [[repository]] ufficiale Debian e impartire i seguenti comandi:
Riga 82: Riga 95:
# apt-get install pepperflashplugin-nonfree
# apt-get install pepperflashplugin-nonfree
</pre>
</pre>
 +
-->
-
 
+
{{Warningbox|Google Chrome dalla versione 54 non include più il plugin Pepper Flash e allo stato attuale (dicembre 2016) è impossibile utilizzare i repository Debian. Pertanto è necessario intervenire tramite installazione manuale.}}
-
{{Box | Nota | Da marzo 2016 Google ha dismesso il supporto del browser Chrome e relativi plugin integrati, per [[Wheezy]] e tutti i sistemi Linux a 32 bit. <br />Il plugin PepperFlash per le architetture a 32 bit, è scaricabile in formato ''.tar.gz per Linux'' dalla pagina ufficiale<sup>[[#Link esterni|[4]]]</sup> di Adobe ed é installabile tramite procedura manuale. <br /> Discussione di riferimento [http://forum.debianizzati.org/viewtopic.php?f{{=}}17&t{{=}}51832&sid{{=}}aa607838608d9248aa76e4a84276dafe&start{{=}}60#p204081: Aggiornare pepperflashplugin-nonfree 32 bit]}}
+
=== Installazione manuale ===
=== Installazione manuale ===
 +
Il plugin Pepper Flash di Google per le architetture a 32 e a 64 bit è disponibile nella pagina ufficiale<sup>[[#Link esterni|[4]]]</sup> di Adobe in formato ''.tar.gz'', selezionando il pacchetto '''PPAPI'''. <br /> Maggiori informazioni sono disponibili in questa<sup>[[#Link esterni|[5]]]</sup> discussione sul forum di Debianizzati.
 +
 +
1) In <code>/usr/lib/</code> creare la directory <code>pepperflashplugin-nonfree/</code>
1) In <code>/usr/lib/</code> creare la directory <code>pepperflashplugin-nonfree/</code>
<pre># mkdir /usr/lib/pepperflashplugin-nonfree/</pre>
<pre># mkdir /usr/lib/pepperflashplugin-nonfree/</pre>
-
2) All'interno di questa inserire i due file presenti nel pacchetto scaricato ed estratto (nel mio caso nella cartella "Scaricati")
+
 
 +
2) All'interno di questa inserire i due file presenti nel pacchetto scaricato ed estratto (nel mio caso nella cartella "Scaricati").
* <code>manifest.json</code> (necessario per comunicare ai browser l'esatta versione del plugin)
* <code>manifest.json</code> (necessario per comunicare ai browser l'esatta versione del plugin)
* <code>libpepflashplayer.so</code>
* <code>libpepflashplayer.so</code>
Riga 97: Riga 114:
-
3) Solo per Chromium è necessario creare con il proprio editor (nel mio caso mousepad) il file '''pepperflashplugin-nonfree''' in <code>''/etc/chromium.d/''</code>  
+
3) Solo per ''Chromium'' è necessario creare con il proprio editor (nel mio caso mousepad) il file '''pepperflashplugin-nonfree''' in <code>''/etc/chromium.d/''</code>  
<pre># mousepad /etc/chromium.d/pepperflashplugin-nonfree</pre>
<pre># mousepad /etc/chromium.d/pepperflashplugin-nonfree</pre>
con il seguente contenuto:
con il seguente contenuto:
Riga 105: Riga 122:
-
4) Per Firefox è necessario procedere come spiegato successivamente.<br />
+
4) Per ''Firefox'' è necessario procedere come spiegato successivamente.<br />
-
Tenere a mente che ad ogni aggiornamento manuale del plugin pepperflash, sarà necessario cancellare dal proprio profilo Firefox il file <code>''pluginreg.dat''</code> (memorizza il numero di versione dei plugin) , si ricreerà automaticamente al successivo avvio del browser.
+
Tenere a mente che ad ogni aggiornamento manuale del plugin pepperflash, sarà necessario cancellare dal proprio profilo Firefox (vale anche per Icedove/Thunderbird) il file <code>''pluginreg.dat''</code> (memorizza il numero di versione dei plugin) , si ricreerà automaticamente al successivo avvio del browser.
-
==== Aggiornamento ====
+
==== Aggiornamento manuale ====
-
Per aggiornare il plugin installato manualmente, occorre scaricare la nuova versione dal sito e ripetere la procedura.
+
Per aggiornare il plugin, occorre scaricare la nuova versione dal sito e ripetere la procedura.
== Freshplayerplugin ==
== Freshplayerplugin ==
-
È un plugin che permette di utilizzare PepperFlashPlayer su browser basati su tecnologia NPAPI come ad esempio Iceweasel/Firefox.
+
È un plugin che permette di utilizzare Pepper Flash Player su browser basati su tecnologia NPAPI come ad esempio Iceweasel/Firefox.
-
Presente nei repository Debian, è disponibile da [[Jessie]] (questa solo dai [[backport]]) e successivi.
+
Presente nei repository Debian, è disponibile da [[Jessie]] [[backport]] e successivi.
Per installare Freshplayerplugin è necessario abilitare la sezione '''contrib''' del [[repository]] ufficiale Debian e impartire i seguenti comandi:
Per installare Freshplayerplugin è necessario abilitare la sezione '''contrib''' del [[repository]] ufficiale Debian e impartire i seguenti comandi:
Riga 120: Riga 137:
# apt-get install browser-plugin-freshplayer-pepperflash
# apt-get install browser-plugin-freshplayer-pepperflash
</pre>
</pre>
 +
{{Warningbox| A causa del problema citato in precedenza riguardante il pacchetto ''pepperflashplugin-nonfree'', procedere come segue.}}
 +
 +
<pre>
 +
# apt-get update
 +
# apt-get install browser-plugin-freshplayer-pepperflash --no-install-recommends
 +
</pre>
 +
 +
== Mozilla: convivenza plugin Flash Adobe e Freshplayerplugin  ==
 +
Nell'ipotetica eventualità che sul sistema siano presenti entrambi e che il plugin Flash di Adobe sia stato installato tramite repository, é possibile utilizzare le [[Alternatives]] per controllare e definire la priorità di utilizzo.
 +
<pre># update-alternatives --config flash-mozilla.so</pre>
== Link esterni ==
== Link esterni ==
[1] [http://get.adobe.com/it/flashplayer/ Pagina per il download di Flash Player] <br/>
[1] [http://get.adobe.com/it/flashplayer/ Pagina per il download di Flash Player] <br/>
[2] [http://www.adobe.com/software/flash/about/ Test di funzionamento] <br/>
[2] [http://www.adobe.com/software/flash/about/ Test di funzionamento] <br/>
-
[3] [http://forum.debianizzati.org/viewtopic.php?f=7&t=41290&start=0: Discussione su Debianizzati.org] <br/>
+
[3] [http://forum.debianizzati.org/viewtopic.php?f=7&t=41290&start=0: Discussione su Debianizzati.org Pulizia cache] <br/>
[4] [https://get.adobe.com/flashplayer/otherversions/ Pagina per il download di Flash Player-Altre versioni] <br/>
[4] [https://get.adobe.com/flashplayer/otherversions/ Pagina per il download di Flash Player-Altre versioni] <br/>
-
 
+
[5] [http://forum.debianizzati.org/viewtopic.php?f=17&t=51832&sid=aa607838608d9248aa76e4a84276dafe&start=60#p204081 Discussione forum: Aggiornare pepperflashplugin-nonfree 32 bit]
{{Autori
{{Autori

Versione delle 11:29, 28 set 2019

Lock.png ATTENZIONE: questa guida tratta software a sorgente chiuso e potenzialmente non conforme alle Debian Free Software Guidelines.
Un'alternativa completamente libera è Gnash.


Debian-swirl.png Versioni Compatibili
Debian 9 "Stretch"
Verificala con Buster

Indice


Info.png Nota
Da dicembre 2016 sul sito di Adobe è disponibile il plugin Flash per Linux aggiornato a nuove versioni esattamente come avviene per altri sistemi operativi (Windows e Mac). Il plugin non supporta tutte le caratteristiche implementate in PepperFlashPlayer.

Copyright

Il plugin Adobe Flash Player è un software proprietario. Nella pagina descrittiva del pacchetto  "flashplugin-nonfree in Debian" è presente questo avvertimento:

WARNING: Installing this Debian package causes the Adobe Flash Player to be downloaded from www.adobe.com. The End User License Agreement of the Adobe Flash Player is available at www.adobe.com.

L'avviso informa che il pacchetto scaricherà il plugin direttamente dal sito di Adobe e che l'accordo di licenza per l'utente finale è disponibile sul medesimo sito.

Installazione da repository

Warning.png ATTENZIONE
Da gennaio 2017 è impossibile installare il plugin flash tramite il pacchetto flashplugin-nonfree presente nei repository Debian. È necessario intervenire tramite installazione manuale.


Nel caso sul sistema in uso sia presente una vecchia installazione del pacchetto flashplugin-nonfree prelevato dai repository Debian, procedere con la sua disinstallazione poi proseguire con l'installazione manuale.

Disinstallazione pacchetto

Eseguire i seguenti comandi:

# update-flashplugin-nonfree --uninstall

e successivamente

# apt-get remove flashplugin-nonfree

Installazione manuale

Per l'installazione manuale dell'ultima versione, occorre scaricare il pacchetto per Linux .tar.gz NPAPI adatto alla propria architettura (32 o 64 bit) dalla pagina ufficiale[1] di Adobe ed estrarre il file libflashplayer.so all'interno della directory dei plugin.

La directory dei plugin varia a seconda dei browser o delle direttive che indichiamo nel browser per la ricerca dei plugin. Se non esiste va creata.

Alcune delle posizioni dei browser più comuni, sempre che al browser non sia indicata una direttiva specifica.

Bulb.png Suggerimento
  • per comodità è possibile estrarre il file libflashplayer.so in una directory a nostro piacimento e creare all'interno delle directory dei plugin dei link simbolici che puntino ad esso;
  • se non si ha un sistema multiutenza si può scegliere di creare la directory ~/.mozilla/plugins/ e inserirvi il file libflashplayer.so.


Aggiornamento manuale

Per aggiornare la versione del plugin, occorre scaricare la nuova versione dal sito ufficiale. Una volta scompattato il pacchetto, posizionare il nuovo libflashplayer.so come indicato in precedenza.


Test

Per verificare il corretto funzionamento, visitare questa pagina[2]. Se il plugin è stato installato correttamente, avrete modo di verificare anche la versione installata.

Pulizia cache

Il player di flash lascia traccia della nostra navigazione, per maggiori informazioni consultare questa[3] discussione sul forum di Debianizzati.

Per maggiore sicurezza è consigliabile creare ed eseguire periodicamente uno script che chiameremo cleanflash.sh, e al cui interno inseriremo:

#!/bin/bash
rm -Rf $HOME/.adobe/ 2> /dev/null
rm -Rf $HOME/.macromedia/  2> /dev/null

In questo caso si rimuove tutta la radice delle directory, queste verranno ricreate in automatico al primo utilizzo di flashplayer.

Per comodità si può inserire lo script in cron.

Per gli utenti di KDE3 o KDE4, basta copiare lo script cleanflash.sh o creare un link simbolico nella directory /home/USER/.kde/shutdown (se la dir /shutdown non esiste occorre crearla).
In questo modo la pulizia verrà effettuata al logout di KDE.

Oppure inserire il comando come Alias in /home/user/.bashrc :

alias ccf='/bin/rm -R $HOME/.adobe/ ;/bin/rm -R $HOME/.macromedia/ '

in questo modo garantiremo la nostra privacy eliminando le directory che portano il nome del sito.


Pepper Flash Player

È un plugin proprietario sviluppato da Google, utilizza le API PPAPI, funziona solamente sui browser: Chrome, Chromium dalla versione 34 (e altri basati su questo) e Opera dalla versione 26.x.
Pepper Flash Player integra le versioni aggiornate rilasciate da Adobe Flash Player e offre funzionalità non presenti in quest'ultimo.


Warning.png ATTENZIONE
Google Chrome dalla versione 54 non include più il plugin Pepper Flash e allo stato attuale (dicembre 2016) è impossibile utilizzare i repository Debian. Pertanto è necessario intervenire tramite installazione manuale.


Installazione manuale

Il plugin Pepper Flash di Google per le architetture a 32 e a 64 bit è disponibile nella pagina ufficiale[4] di Adobe in formato .tar.gz, selezionando il pacchetto PPAPI.
Maggiori informazioni sono disponibili in questa[5] discussione sul forum di Debianizzati.


1) In /usr/lib/ creare la directory pepperflashplugin-nonfree/

# mkdir /usr/lib/pepperflashplugin-nonfree/


2) All'interno di questa inserire i due file presenti nel pacchetto scaricato ed estratto (nel mio caso nella cartella "Scaricati").

# cp Scaricati/flash_player_ppapi_linux.i386/manifest.json /usr/lib/pepperflashplugin-nonfree/manifest.json
# cp Scaricati/flash_player_ppapi_linux.i386/libpepflashplayer.so /usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so


3) Solo per Chromium è necessario creare con il proprio editor (nel mio caso mousepad) il file pepperflashplugin-nonfree in /etc/chromium.d/

# mousepad /etc/chromium.d/pepperflashplugin-nonfree

con il seguente contenuto:

flashso="/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so"
flashversion=`strings $flashso 2> /dev/null | grep LNX | cut -d ' ' -f 2 | sed -e "s/,/./g"`
CHROMIUM_FLAGS="$CHROMIUM_FLAGS --ppapi-flash-path=$flashso --ppapi-flash-version=$flashversion"


4) Per Firefox è necessario procedere come spiegato successivamente.
Tenere a mente che ad ogni aggiornamento manuale del plugin pepperflash, sarà necessario cancellare dal proprio profilo Firefox (vale anche per Icedove/Thunderbird) il file pluginreg.dat (memorizza il numero di versione dei plugin) , si ricreerà automaticamente al successivo avvio del browser.

Aggiornamento manuale

Per aggiornare il plugin, occorre scaricare la nuova versione dal sito e ripetere la procedura.

Freshplayerplugin

È un plugin che permette di utilizzare Pepper Flash Player su browser basati su tecnologia NPAPI come ad esempio Iceweasel/Firefox. Presente nei repository Debian, è disponibile da Jessie backport e successivi.

Per installare Freshplayerplugin è necessario abilitare la sezione contrib del repository ufficiale Debian e impartire i seguenti comandi:

# apt-get update
# apt-get install browser-plugin-freshplayer-pepperflash
Warning.png ATTENZIONE
A causa del problema citato in precedenza riguardante il pacchetto pepperflashplugin-nonfree, procedere come segue.


# apt-get update
# apt-get install browser-plugin-freshplayer-pepperflash --no-install-recommends

Mozilla: convivenza plugin Flash Adobe e Freshplayerplugin

Nell'ipotetica eventualità che sul sistema siano presenti entrambi e che il plugin Flash di Adobe sia stato installato tramite repository, é possibile utilizzare le Alternatives per controllare e definire la priorità di utilizzo.

# update-alternatives --config flash-mozilla.so

Link esterni

[1] Pagina per il download di Flash Player
[2] Test di funzionamento
[3] Discussione su Debianizzati.org Pulizia cache
[4] Pagina per il download di Flash Player-Altre versioni
[5] Discussione forum: Aggiornare pepperflashplugin-nonfree 32 bit




Guida scritta da: Ferdybassi 16:17, 31 dic 2009 (CET)

Swirl-auth60.png Debianized 60%

Estesa da:
Verificata da:
Mm-barabba 00:58, 6 set 2010 (CEST)
Selky 02:58, 20 ott 2015 (CEST)

Verificare ed estendere la guida | Cos'è una guida Debianized

Strumenti personali
Namespace
Varianti
Azioni
Navigazione
Risorse
Strumenti