Il repository DotDeb

Da Guide@Debianizzati.Org.

Versione delle 12:35, 13 mag 2015, autore: HAL 9000 (Discussione | contributi)
(diff) ← Versione meno recente | Versione attuale (diff) | Versione più recente → (diff)
I repository
Arrow left.png

Introduzione ai repository

Repository ufficiali di Debian

Repository esterni

Extra

Arrow right.png



Debian-swirl.png Versioni Compatibili
Debian 6 "Squeeze"
Debian 7 "Wheezy"
Debian 8 "Jessie"
Verificala con Stretch

Indice


Introduzione

Dotdeb è un repository non ufficiale, mantenuto da uno sviluppatore Debian, Guillaume Plessis, e contiene i pacchetti necessari per tenere aggiornato un server LAMP, come ad esempio:

Dotdeb supporta:

Configurazione del repository

Modificate il vostro /etc/apt/sources.list aggiungendo le righe adatte alla vostra versione di Debian.

Squeeze

deb http://packages.dotdeb.org squeeze all
deb-src http://packages.dotdeb.org squeeze all

PHP 5.4

Se volete utilizzare PHP 5.4 al posto della versione 5.3 di default aggiungete anche le seguenti righe:

deb http://packages.dotdeb.org squeeze-php54 all
deb-src http://packages.dotdeb.org squeeze-php54 all

Wheezy

deb http://packages.dotdeb.org wheezy all
deb-src http://packages.dotdeb.org wheezy all

PHP 5.5

Se volete utilizzare PHP 5.5 al posto della versione 5.4 di default aggiungete anche le seguenti righe:

deb http://packages.dotdeb.org wheezy-php55 all
deb-src http://packages.dotdeb.org wheezy-php55 all

PHP 5.6

Se preferite PHP 5.6 (senza Zend thread safety) aggiungete invece le righe:

deb http://packages.dotdeb.org wheezy-php56 all
deb-src http://packages.dotdeb.org wheezy-php56 all

PHP 5.6 con Zend thread safety

Per PHP 5.6 con Zend thread safety invece le righe sono:

deb http://packages.dotdeb.org wheezy-php56-zts all
deb-src http://packages.dotdeb.org wheezy-php56-zts all

Jessie

deb http://packages.dotdeb.org jessie all
deb-src http://packages.dotdeb.org jessie all

Installazione

Per prima cosa scaricate e aggiungete la chiave GnuPG:

# wget http://www.dotdeb.org/dotdeb.gpg
# cat dotdeb.gpg | sudo apt-key add -

poi aggiornate il sistema con:

# apt-get update

e infine installate con apt o aptitude il software che vi occorre.




Guida scritta da: Ferdybassi 16:21, 2 apr 2011 (CEST)

Swirl-auth40.png Debianized 40%

Estesa da:
Verificata da:
BubuXP 01:40, 25 lug 2014 (CEST)

Verificare ed estendere la guida | Cos'è una guida Debianized

Strumenti personali
Namespace
Varianti
Azioni
Navigazione
Risorse
Strumenti