Debian on a presario 2141EU

Da Guide@Debianizzati.Org.

Debian-swirl.pngVersioni compatibili

Debian 3.1 "Sarge"

Indice

Introduzione

Questa pagina descrive la configurazione della distribuzione Debian GNU/Linux sul mio presario 2141EU (serie 2100).

Dando da shell lspci si ottiene (o perlomeno ottengo):

 0000:00:00.0 Host bridge: ATI Technologies Inc AGP Bridge [IGP 320M] (rev 13)
 0000:00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 320M] (rev 01)
 0000:00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
 0000:00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 02)
 0000:00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
 0000:00:08.0 Modem: ALi Corporation M5457 AC'97 Modem Controller
 0000:00:0a.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
 0000:00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
 0000:00:11.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
 0000:00:12.0 Ethernet controller: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller
 0000:01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility U1

Controller USB

È sufficiente abilitare il supporto per OHCI (CONFIG_USB_OHCI_HCD) presente nel kernel. Per usare gli hard disk esterni o le pen-drive è sufficiente creare una cartella dove saranno montate le periferiche usb (/dev/sda1), io ho creato una cartelle nella radice, /usb. La riga di fstab sarà:

/dev/sda1 /usb auto defaults,noauto,user 0 0

Ma può essere cambiata (sopratutto le opzioni, che non ho ancora avuto voglia di spulciare).

Scheda Audio:

Anche qui è sufficiente abilitare il supporto specifico per gli alsa (CONFIG_SND_ALI545). Può capitare che ad un utente venga negato l'accesso ad alcune periferiche (/dev/snd/), per far funzionare comunque la scheda audio si possono cambiare i permessi o la proprietà dei file che si utilizzano.

Modem

Non testato.

Slot PCMCIA

Non testato, ma non ricevo particolari errori in fase di boot.

DMA

Il DMA è un protocollo che velocizza il trasferimento dati su periferiche IDE. Per attivarlo è necessario includere nel kernel il supporto per il chipset ALi M1533 (CONFIG_BLK_DEV_ALI15X3) e l'opzione che permette di abilitare di default il DMA (CONFIG_IDEDMA_PCI_AUTO). Credo sia anche possibile utilizzare l'UDMA, per velocizzare ancor più i trasferimenti di I/O ma (stranamente) non ho ancora avuto voglia di provarci : ).

Scheda ethernet

Il driver della scheda di rete è nel kernel (CONFIG_NATSEMI) e funziona perfettamente.

Scheda video

Il driver di questa scheda video è presente nel kernel (CONFIG_FB_RADEON), ma nelle versioni precedenti al 2.6.11 vengono restituiti alcuni errori, che non corrispondono però a reali problemi. L'accelerazione hardware non funziona in quanto non sono disponibili i driver dalla casa madre (ATI) per le schede mobility.

L'uscita S-Video (per guardare i vostri filmati _amatoriali_ sulla televisione) è discretamente supportata. Il brutto è che televisore e schermo del PC non posso funzionare insieme; o uno o l'altro. Non sono ancora riuscito ad ottenere una buona risoluzione dell'immagine sulla TV, forse sbaglio io qualche cosa, ma è comunque una qualità accettabile per guardare un film. Usate atitvout.

L'uscita VGA funziona perfettamente, senza bisogno di particolari configurazioni.

ACPI

Il controllo energetico (comando ventole ecc.) è supportato correttamente. Sfortunatamente non sono ancora riuscito a far funzionare nel modo corretto la switch di velocità della CPU, anche se nel kernel il supporto è abilitato; credo però sia solo un MIO problema, perché altre persone mi hanno detto che su portatili della stessa famiglia funziona alla grande. Staremo a vedere.......

Installazione

Per l'installazione ho dovuto seguire una via un po' perversa, in quanto i nuovi CD della Debian non volevano saperne di funzionare con il mio portatile. La tastiera non veniva riconosciuta dai kernel dei CD d'installazione, quindi non potevo installare. Ho dovuto installare una Woody 3.0r2 con kernel 2.2, quindi cambiare kernel (2.6), configurarlo ed infine aggiornare il sistema ad "unstable" tramite apt-get.




Guida scritta da: freem

Swirl-auth16.png Debianized 16%

Verificata da:
Estesa da:

Verificare ed estendere la guida | Cos'è una guida Debianized

Strumenti personali
Namespace
Varianti
Azioni
Navigazione
Risorse
Strumenti